Author Topic: CLEO35 to Uno: apparent interface error  (Read 1828 times)

k1mgy

  • Full Member
  • ***
  • Posts: 8
    • View Profile
CLEO35 to Uno: apparent interface error
« on: September 04, 2017, 02:53:54 PM »
To get our engineering prototype quickly ready to test (through touch-enabled screen), and after too much trouble doing the same through Qt5 and Framebuffer in linux (our product's system host is linux), we discovered FTDI and Cleo35.

Purchased Cleo35 and Uno (the literature says the Uno is a valid host), only to find out I also need a hardware interface ("RIO Module").  Examining the schematic it appears that the RIO simply translates the UNO connector vertically, allowing the UNO to be attached (although with the UNO facing down).  I therefore hacked an interface by soldering male pins to the reverse of the UNO (photo below).

Before attaching the UNO I performed the firmware update (Cleo 2.1.2).  Then attached the UNO and powered through both the USB and an external supply to the Uno's power connector.  All seemed just fine.  Attempted to perform the LoadFlash.ino and receive these errors:

    warning: espcomm_sync failed
    error: espcomm_open failed
    error: espcomm_upload_mem failed
    error: espcomm_upload_mem failed

After this, CLeO shows Error Trap on its LCD

    CLeO Error Trap
    Command
    CleO.Noop()
    returned error -14: assertion

    Cannot open file "("\

Note that I copied the required SD card files to a 4GB industrial micro SD (FAT32 format) and it is onboard CleO.


I re-checked the connections and determined that many were marked NC, so I got those pins out of the way (second photo).

Same error.

The instructions provide no direction as to the settings of the jumpers on the CLEO35.  Presently they are as received from the factory:

   CN10: 5V
   CN9: D10
   CN12: IRQ>>D3

I could skip a step and go directly to my MCU through SPI, but it appears this LoadFlash code must be written to the CLEO, and apparently the only way to do so is through the Arduino.

So, what to do from here?

    [Suggestions:
      1. Docs should be explicit about jumper settings and connections between Uno and Cleo35
      2. Error messages should have a reference
      3. Intent of instructions, in this case, the LoadFlash, should be described.  I have no idea what it does.
      4. Marketing literature should clearly spell out that if you are to use an Uno, you must also purchase the IO adapter. ]


« Last Edit: September 04, 2017, 03:08:42 PM by k1mgy »

k1mgy

  • Full Member
  • ***
  • Posts: 8
    • View Profile
Re: CLEO35 to Uno: apparent interface error
« Reply #1 on: September 04, 2017, 04:01:18 PM »
Fixed it myself.  Operator error and the error messages should have given me a clue.

The last time I programmed something with my Arduino software was when I did some work on an ESP wifi board.  I simply had not selected the Uno as the target.

Ran the LoadFlash.  It worked, and stepped me through a screen calibration with "Load Complete" on the display.

For those following along, the default jumper settings for the Cleo work with the Arduino Uno, and my connector hack also works fine.

CleOSupport

  • Administrator
  • Full Member
  • *****
  • Posts: 51
    • View Profile
Re: CLEO35 to Uno: apparent interface error
« Reply #2 on: September 04, 2017, 04:11:00 PM »
Hello,

Thanks for your update, and we're glad to hear that it's working well.

The LoadFlash copies the images and fonts from the SD card into the on-board eFlash so that examples which use the eFlash can get them. CleO allows you to use either SD card or eFlash as the location for these. Please see tutorial number 17 (http://www.cleostuff.com/cleostuff.com/CleO%20Help/CleO35%20Help/index.html) for information on the file storage.

Thanks, CleOSupport